Code

Opened 5 years ago

Closed 5 years ago

#9763 closed (duplicate)

is_dirty() in the transactions middleware blocks commit for Postgre

Reported by: Jeffrey Owned by: nobody
Component: Database layer (models, ORM) Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In its default operation Postgre makes a shadow copy of a table for reading, and this persists until you explicitly commit your transaction. However, the TransactionsMiddleware class only calls commit when transaction.is_dirty() returns true. If you only read from the database, commit will never get called.

Possibly the is_dirty() check should be bypassed (or perhaps always return True) for postgres.

Attachments (0)

Change History (3)

comment:2 Changed 5 years ago by shai

PostgreSQL here is just a special case; the behavior is wrong everywhere. See #9964.

comment:3 Changed 5 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9964.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.