Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9613 closed (fixed)

Missing authtestdata.json in Django-1.0.1-final.tar.gz

Reported by: aubonbeurre Owned by: jbronn
Component: Uncategorized Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by jbronn)

Sorry if it is a dup, but contrib/auth/fixtures/authtestdata.json and contrib/auth/tests/templates/registration/login.html seem to be missing in Django-1.0.1-final.tar.gz, compared to svn.

This shows-up when doing regression testing of the auth module:

FAIL: test_password_change_fails_with_invalid_old_password (django.contrib.auth.tests.views.ChangePasswordTest)

File "j:\sources\facedetector\djangoserver\pythonlib\django\contrib\auth\tests\views.py", line 115, in login
    self.assertEquals(response.status_code, 302)
AssertionError: 200 != 302

I'm on Windows.

Attachments (1)

manifest_contrib_changes.diff (758 bytes) - added by jbronn 6 years ago.
Adds missing contrib directories without code in auth and formtools to the MANIFEST.in

Download all attachments as: .zip

Change History (9)

comment:1 Changed 6 years ago by kmtracey

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Yes, the problem is known. The changes needed to include these files in the distribution tarball were made in r9437/r9474. I don't know what the plans are for rolling a new release, though.

comment:2 Changed 6 years ago by kmtracey

I meant r9473, of course.

comment:3 Changed 6 years ago by kmtracey

Sorry, these have not been fixed in the code yet -- I was clearly distracted when I read this originally since I thought it mentioned gis, not auth. We need to fix these as well.

Changed 6 years ago by jbronn

Adds missing contrib directories without code in auth and formtools to the MANIFEST.in

comment:4 Changed 6 years ago by jbronn

  • Has patch set
  • Owner changed from nobody to jbronn
  • Status changed from new to assigned

Confirmed. Also, the templates for django.contrib.formtools were not included in MANIFEST.in.

comment:5 Changed 6 years ago by jbronn

  • Description modified (diff)

comment:6 Changed 6 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [9478]) Fixed #9613 -- Added a bunch of files that were missing when the distribution
tarball is created. Thanks, Justin Bronn.

comment:7 Changed 6 years ago by mtredinnick

(In [9479]) [1.0.X] Fixed #9613 -- Added a bunch of files that were missing when the
distribution tarball is created. Thanks, Justin Bronn.

Backport of r9478 from trunk.

comment:8 Changed 6 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top