Opened 7 years ago

Closed 7 years ago

#9058 closed (duplicate)

Incorrect Documentation Note for modelformset_factory

Reported by: drozzy Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

On the page:
http://docs.djangoproject.com/en/dev/topics/forms/modelforms/#id1

the Note says:

One thing to note is that modelformset_factory uses formset_factory and by default uses can_delete=True.

This is actually not the case! In the code the default value for the can_delete is False!
See line 276:
http://code.djangoproject.com/browser/django/trunk/django/forms/formsets.py#L276

Change History (2)

comment:1 Changed 7 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

Yes. This is a documentation mishap. can_delete=True should have been marked on inlineformset_factory and not modelformset_factory.

comment:2 Changed 7 years ago by brosner

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like this is a duplicate of #9027.

Note: See TracTickets for help on using tickets.
Back to Top