Code

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8988 closed (duplicate)

Wiki cleanup and restructure

Reported by: httpdss Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords: wiki, djangocon
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Looking at the wiki as another source of very usefull documentation, I personally think that it need some cleanup.
Thing to take into account:

  • Url naming: some urls do not use the standard naming convention that wiki traditionally use.
  • Empty pages
  • Content duplication: found pages with same content and different url names
  • Link only pages: some pages include only a link and nothing else.

On a second stage it would be interesting to have a wiki restructure based on the use of subpages in order to categorize the pages more wisely.

Attachments (0)

Change History (6)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7428.

comment:2 Changed 6 years ago by ubernostrum

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Whoops, wrong ticket.

comment:3 Changed 6 years ago by ericholscher

  • Keywords wiki, djangocon added; wiki removed

Yea, this was talked about at djangocon. I think this would be really useful. I also feel it is a consequence of the official documentation being so good. A lot of people also post stuff that could be on the wiki in their personal blogs (to get credit and comments etc.) which I think makes sense.

So it might make more sense to maybe somehow include the functionality in #8945 along with this, or instead of this, or some hybrid. Perhaps Having the official docs link to an 'unofficial' page on the topic that would be in the wiki or something like that...

comment:4 Changed 6 years ago by ericholscher

(and the wiki would then also link to outside blogs and other stuff, as well as perhaps have it's own content)

comment:5 follow-up: Changed 6 years ago by adrian

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing this in favor of #8945, which is much more specific in its goal. (Generally, saying broad stuff like "we should improve the wiki" isn't a great use of the ticket system.)

comment:6 in reply to: ↑ 5 Changed 6 years ago by httpdss

Replying to adrian:

Closing this in favor of #8945, which is much more specific in its goal. (Generally, saying broad stuff like "we should improve the wiki" isn't a great use of the ticket system.)


i think the ticket got missinterpreted because of including two tasks on one ticket (my bad).
The primary focus of the ticket is to clean up the existing wiki taking into account the points listed.
This task isnt treated on ticket #8945. the ticket mentioned by Adrian focuses on the second task of this ticket which is the wiki restructuring.


Consider the reopening of this ticket due to the lack of coverage on cleanup that ticket #8945 has.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.