Code

Opened 6 years ago

Closed 6 years ago

#8987 closed (duplicate)

Forms validation documentation isn't clear about clean functions needing to return the cleaned value.

Reported by: FunkyBob Owned by: nobody
Component: Documentation Version: 1.0
Severity: Keywords: forms
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

It's obvious once you know it, but the only point I could see where it was shown that clean*() are expected to return a value was in the example Field code. No example is given for clean_<fieldname>.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Duplicate of #7428.

comment:2 Changed 6 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.