Code

Opened 6 years ago

Closed 6 years ago

#8970 closed (duplicate)

Explicit argument should be added to admin 'autodiscover()'

Reported by: joshuajonah Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: josh@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Just an idea, but it would be nice to be able to give an argument to autodiscover() that would target an admin.py. Many people use a collective admin.py in their project to call their app admin.py's. This would avoid having to manually import the project admin.py in settings.

example:

admin.autodiscover(admin)

Attachments (0)

Change History (3)

comment:1 in reply to: ↑ description Changed 6 years ago by joshuajonah

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Also it would allow different autodiscover configurations for testing etc.

comment:2 Changed 6 years ago by joshuajonah

  • Cc josh@… added

comment:3 Changed 6 years ago by julien

  • Resolution set to duplicate
  • Status changed from new to closed

This is a dupe of #8500 and #8572. The patch proposed in the latter should help you in this case.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.