Code

Opened 6 years ago

Closed 5 years ago

#8953 closed (duplicate)

Timezone support at the model level

Reported by: simon Owned by: nobody
Component: Uncategorized Version: 1.0
Severity: Keywords: djangocon
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by simon)

This should probably rely on dateutil and/or pytz - so you wouldn't be able to use DateTimeTzField without having those installed.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by simon

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by brosner

I would like to point out http://code.google.com/p/django-timezones/ as something that was created for Pinax. It tries to be as unintrusive as possible. There are some less than ideal ways of accomplishing things, but it certainly is a start and hopefully heading down the right direction with cleanups for Django proper.

comment:3 Changed 6 years ago by jhenry

There is another implementation of this in use on http://chicago.decider.com/ on launchpad.

https://code.launchpad.net/~theonion/bulbs/trunk

comment:4 Changed 6 years ago by korpios

What jhenry said; also see my comment:

http://code.djangoproject.com/ticket/2626#comment:13

In a nutshell, we have it working without needing to hack up Django core.

comment:5 Changed 5 years ago by jacob

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #2626.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.