Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#8793 closed (duplicate)

using the file.url can not download the uploaded file

Reported by: etng Owned by: nobody
Component: File uploads/storage Version: master
Severity: Keywords: normcase path
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

when I digg into the source code,I found that in line 47 of django.db.models.fields.files,the call to self.storage.path(self.name) returns a os.path.normpath processed file path, it changes the file's full path to all lower case, but the url is not following this change, so this error happens!

sorry, I can not submit a good patch for it,but I think it will resolved by you gurus.

thank you

Change History (2)

comment:1 Changed 7 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8593.

comment:2 Changed 3 years ago by jacob

  • milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.
Back to Top