Code

Opened 6 years ago

Closed 4 years ago

#8778 closed (fixed)

validate_unique - different phrases have the same translations

Reported by: Petr Marhoun <petr.marhoun@…> Owned by: nobody
Component: Internationalization Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the new function validate_unique from [8805] two new translations phrases are added. One for one field (unique), one for more fields (unique_together). There is a difference in code - in the first phrase "field_label" variable is used, in the second phrase "field_labels" variable is used. But in the translation strings only "field_label" is used. It means that for some languages (at least for mine) it is almost impossible to have nice translations of these strings. Could it be possible to change the second "field_label" to "field_labels"?

Attachments (2)

validate-unique-field-labels.diff (854 bytes) - added by Petr Marhoun <petr.marhoun@…> 6 years ago.
00-unique-together-field-labels.diff (883 bytes) - added by Petr Marhoun <petr.marhoun@…> 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Petr Marhoun <petr.marhoun@…>

comment:1 Changed 6 years ago by jacob

  • milestone changed from 1.0 to post-1.0
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

That was a deliberate choice -- with string freeze on we're making as few changes as possible for 1.0. We'll fix this after when we can make more string changes without messing with translators' heads.

Changed 6 years ago by Petr Marhoun <petr.marhoun@…>

comment:2 Changed 5 years ago by anonymous

  • milestone post-1.0 deleted

Milestone post-1.0 deleted

comment:3 Changed 5 years ago by jacob

  • Triage Stage changed from Unreviewed to Accepted

comment:4 follow-up: Changed 4 years ago by ramiro

We missed the chance of fixing this for 1.1, for 1.2 this has been solved by the model validation branch merge that also interoduced some refactoring on the modelform validation code.

I'm leaving this ticket open because I'm not sure if we can change/add translatable literals in the 1.1.x maintenance branch. If we can't then please close this ticket.

comment:5 in reply to: ↑ 4 Changed 4 years ago by ramiro

  • Resolution set to fixed
  • Status changed from new to closed

Replying to ramiro:

I'm leaving this ticket open because I'm not sure if we can change/add translatable literals in the 1.1.x maintenance branch. If we can't then please close this ticket.

I confirmed with Jannis Leidel via IRC that we can't change or add literals in 1.1.x because we can't require translators to update translations there.

Closing ticket as fixed then.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.