Opened 7 years ago

Closed 7 years ago

#8492 closed (duplicate)

Nesting applications can cause name collision in admin

Reported by: chris_dickinson Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Installing two applications (one nested in a module) with the same name and model names will cause a name collision between the models in admin.

for example:

INSTALLED_APPS = (

'django.contrib.auth',
'django.contrib.contenttypes',
'django.contrib.sessions',
'django.contrib.sites',
'django.contrib.admin',
'rhs',
'nest.lhs', #comment this app to make the application work again
'lhs',

)

where rhs, lhs, and nest.lhs all contain a models.py with the same model name, and functionally identical admin.py files.

Change History (1)

comment:1 Changed 7 years ago by ubernostrum

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3591.

Note: See TracTickets for help on using tickets.
Back to Top