Opened 7 years ago

Closed 6 years ago

#8478 closed (duplicate)

Change Canadian postal code for Newfoundland

Reported by: dharris Owned by: dharris
Component: contrib.localflavor Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

django.contrib.localflavor.ca.ca_provinces has "NF" as the postal code for Newfoundland and Labrador. According to the Canada Post web site, the proper abbreviation is "NL".

The wikipedia article on Canadian subnational postal abbreviations shows "NF" as a former abbreviation.

Attachments (1)

8520.diff (1.2 KB) - added by Piotr Lewandowski <django@…> 7 years ago.
django.contrib.localflavor.ca.ca_provinces 'NF' -> 'NL', trailing spaces removed

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by Piotr Lewandowski <django@…>

django.contrib.localflavor.ca.ca_provinces 'NF' -> 'NL', trailing spaces removed

comment:1 Changed 7 years ago by Piotr Lewandowski <django@…>

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 7 years ago by dharris

  • Patch needs improvement set

This needs a better patch. The code itself should refer to NL in the PROVINCES_NORMALIZED (including recognizing the old "nf" and returning "NL"). Also, there should be changes to tests/regressiontests/forms/localflavor/ca.py

I will work on this, but I'm posting this comment to make sure that these items are considered before this ticket is closed.

comment:3 Changed 7 years ago by Piotr Lewandowski <django@…>

  • Owner changed from nobody to dharris

You're 100% right. I'm assigning you to this ticket, since I'll no longer work on it.

comment:4 Changed 6 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #10365, since that ticket contains the comment of why this isn't even necessarily a bug and why changing it is probably a bad idea.

Note: See TracTickets for help on using tickets.
Back to Top