Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#10365 closed (duplicate)

localflavor.ca.ca_provinces incorrect.

Reported by: bartek Owned by: nobody
Component: contrib.localflavor Version: 1.0
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In the tuples provided in this file, Newfoundland and Labrador have an abbreviation of "NF"

This is incorrect, and is actually "NL". I am unsure if this is a recent change but that is the case according to official Canadian websites and even systems like PayPal Pro

Change History (5)

comment:1 Changed 6 years ago by jacob

  • milestone set to 1.1
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 6 years ago by mtredinnick

  • Triage Stage changed from Accepted to Design decision needed

I'd be -1 on making this change. The abbreviation in question isn't a display string: it's the value stored in the database. We haven't made any error with the human-consumable string.

The big argument against changing it is that anybody who is already using this field will now have invalid data in their database. Suddenly they will have stored NF and it won't map to any display string (and entering the same data after the change will put different data into the database).

Moving to "design decision needed"; it's not a no-brainer and it's not a functional bug at the moment.

comment:3 Changed 6 years ago by dharris

I'm +1 on making the change. See my comments on #10456, comment 2

comment:4 Changed 6 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #10456, since it's itnertwined with the changes over there (as per comment 6, there)

comment:5 Changed 4 years ago by jacob

  • milestone 1.1 deleted

Milestone 1.1 deleted

Note: See TracTickets for help on using tickets.
Back to Top