Opened 7 years ago

Closed 7 years ago

#8405 closed (duplicate)

Editing inline-image in admin results in KeyError

Reported by: Uninen Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: inheritance modelinheritance admin keyerror
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I have three models:

class Image(models.Model):
    image = models.ImageField(upload_to='productimages/')

class ExtraImage(Image):
    model = models.ForeignKey('ProductModel')    

class ProductModel(models.Model):
    modelnumber = models.CharField(primary_key=True, max_length=50, unique=True)

and admin interface for them, which has a inline for the extra images:

class ExtraImageInline(admin.TabularInline):
    model = ExtraImage
    extra = 2

class ProductModelAdmin(admin.ModelAdmin):
    inlines = (ModelPropertyInline, ExtraImageInline)

Adding the image works OK, but anything after that (editing or deleting) results in KeyError:

 File "/home/customer/django/django/forms/models.py", line 292, in save_existing_objects
   obj = existing_objects[form.cleaned_data[self.model._meta.pk.attname]]

KeyError: 'image_ptr_id'

Tested with dev server with Django r8435 and apache+mod_python running Django r8355.

Change History (1)

comment:1 Changed 7 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7888.

Note: See TracTickets for help on using tickets.
Back to Top