Code

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#8145 closed (fixed)

Codenames of default permissions not listed in documentation

Reported by: Josh_Rosen Owned by: jezdez
Component: Documentation Version: master
Severity: Keywords: permissions, authentication
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The documentation at http://www.djangoproject.com/documentation/authentication/#default-permissions describing the default add, change, and delete permissions does not list the codenames needed to use those permissions. Although the codenames of these permissions are findable by looking at the database or Django's source, it would be nice to have them stated explicitly in the documentation.

Attachments (1)

8145.diff (1.3 KB) - added by timo 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 6 years ago by programmerq

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 5 years ago by dc

#11545 is a duplicate of this ticket and has patch.

Changed 5 years ago by timo

comment:3 Changed 5 years ago by timo

  • Has patch set
  • Triage Stage changed from Accepted to Ready for checkin

added slightly tweaked patch from #11545, thanks emes for the original patch

comment:4 Changed 5 years ago by jezdez

  • Owner changed from nobody to jezdez
  • Status changed from new to assigned

comment:5 Changed 5 years ago by jezdez

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [11909]) Fixed #8145 - Documented the codenames of the default auth permissions

comment:6 Changed 5 years ago by jezdez

(In [11948]) [1.1.X] Fixed #8145 - Documented the codenames of the default auth permissions

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.