Opened 7 years ago

Closed 7 years ago

#8057 closed (duplicate)

Forms clean documentation omits essential

Reported by: Alper Cugun <djangoproject@…> Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: forms, newforms, clean
Cc: Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Needed to dig into the source but the current documentation does not reflect that clean_FOO needs to return the cleaned value.

As in forms.py:
value = getattr(self, 'clean_%s' % name)()
self.cleaned_data[name] = value

So attached is a patch for the forms.txt documentation.

Attachments (1)

forms.patch (1.3 KB) - added by Alper Cugun <djangoproject@…> 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Alper Cugun <djangoproject@…>

comment:1 Changed 7 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 7 years ago by ubernostrum

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7428.

Note: See TracTickets for help on using tickets.
Back to Top