Code

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#8056 closed (duplicate)

Forms clean documentation omits essential

Reported by: Alper Cugun <djangoproject@…> Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: forms, newforms, clean
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Needed to dig into the source but the current documentation does not reflect that clean_FOO needs to return the cleaned value.

As in forms.py:
value = getattr(self, 'clean_%s' % name)()
self.cleaned_data[name] = value

So attached is a patch for the forms.txt documentation.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Alper Cugun <djangoproject@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 6 years ago by Alper Cugun <djangoproject@…>

Sorry duplicate of #8057 (which has the patch).

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.