Code

Opened 6 years ago

Closed 6 years ago

#7719 closed (duplicate)

Configuration do avoid error silencing when rendering template

Reported by: GabrielFalcao Owned by: nobody
Component: Template system Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When developing new form widgets and fields, the possibility to get exceptions like SyntaxError and so it so big.
The current template rendering behavior is awful and non-explicit, i could say that is non-pythonic either.
So, to avoid problems, instead of propose cut this behavior off, i suppose that is better if i would a configuration.

Here comes a patch for it.

Attachments (1)

template_error_silencing_configuration.patch (1.7 KB) - added by GabrielFalcao 6 years ago.
Using a config to avoid error silencing in django templates

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by GabrielFalcao

Using a config to avoid error silencing in django templates

comment:1 Changed 6 years ago by Simon Greenhill

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6907

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.