Code

Opened 6 years ago

Closed 5 years ago

#7401 closed (invalid)

Documentation should note potential problems with SELinux

Reported by: user1274 Owned by: nobody
Component: Documentation Version: master
Severity: Keywords: install mod_python selinux
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description (last modified by jacob)

Was following the documentation for installation with Apache & mod_python. Following the Django best-practices, I started a Django project outside of "where PHP projects live" - i.e., not where Apache serves documents. Little did I know that SELinux was by design preventing Apache access outside of its allowable realm. Spent a few days on this, going down different paths/possibilities, etc. A warning in the documentation (to work with or around SELinux) would greatly help newbies (like me) and allow for a smoother, more enjoyable learning curve to this great product.

See also:

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by jacob

  • Description modified (diff)
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from Installation with Apache/mod_python to Documentation should note potential problems with SELinux
  • Triage Stage changed from Unreviewed to Accepted

[Added a more descriptive title]

comment:2 Changed 5 years ago by timo

  • Resolution set to invalid
  • Status changed from new to closed

I think we've decided not to include too many distro-specific notes in the official docs, so I've put these notes on the Distributions page of the Django Wiki.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.