Opened 7 years ago

Closed 7 years ago

#7015 closed (wontfix)

[PATCH] Per-project overrideable application specific settings

Reported by: Joshua "jag" Ginsberg <jag@…> Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


It is often useful for an application to define its own settings that are then overrideable on a per-project basis. This is a patch derived from a method that I've been using in my apps for some time. The app skeleton path adds a file which contains a LocalApplicationSettings class. Its attributes define settings for the application. These settings can be overridden in with a predictable rubric: if the application is named 'foo' and the settings is BAR_SETTING, then by setting FOO_BAR_SETTING in it is overridden for that project.

Attachments (1)

appsettings.patch (1.4 KB) - added by Joshua "jag" Ginsberg <jag@…> 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Joshua "jag" Ginsberg <jag@…>

comment:1 Changed 7 years ago by telenieko

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

Duplicate of #5049

Note: See TracTickets for help on using tickets.
Back to Top