Opened 9 years ago

Closed 8 years ago

#6824 closed (invalid)

django/utils/images.py - import ImageFile fails

Reported by: nate.prouty@… Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords: images PIL utils
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I couldn't attached an image to an instance of a model in the admin interface, so I looked at the traceback and it said it was failing on "import ImageFile" in django/utils/images.py. Modifying it to: from PIL import ImageFile fixed it for me (but naturally I'd rather not have to muck with the django code)

-Nate

Change History (1)

comment:1 Changed 8 years ago by Marc Fargas

Needs documentation: unset
Needs tests: unset
Patch needs improvement: unset
Resolution: invalid
Status: newclosed

Which version of PIL and python are you using? I tried this on 2.4 and 2.5 which PIL 1.1.6 with no problem.
And, how did you install PIL? From it's documentation the import is correct, so something may be wrong in your PYTHONPATH.

If that's not the case, feel free to reopen the ticket with further details. Thanks.

Note: See TracTickets for help on using tickets.
Back to Top