Opened 7 years ago

Closed 7 years ago

#6823 closed (fixed)

ObjectPaginator Error on Lists

Reported by: dmarrah@… Owned by: nobody
Component: Core (Other) Version: master
Severity: Keywords: paginator pagination
Cc: Rick@… Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

django.core.paginator.ObjectPaginator appears to have had some changes today. Paging lists no longer works. Paging QuerySets is still works fine. The issue appears to be in the method ObjectPaginator._get_count(self). (line 175 - SVN 7306)

You might try fixing it by catching a TypeError rather than an AttributeError. I tried this locally and it seemed to fix it.

Attachments (1)

paginator.patch (498 bytes) - added by mbonetti@… 7 years ago.
Patch

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by mbonetti@…

Patch

comment:1 Changed 7 years ago by mbonetti@…

  • Keywords pagiantor pagination added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Confirmed.

I just attached a patch implementing what the reporter suggested and which fixes the issue.

comment:2 Changed 7 years ago by Rick@…

  • Cc Rick@… added
  • Has patch set
  • Keywords paginator added; pagiantor removed

The patch works for me aswell.

comment:3 Changed 7 years ago by ramiro

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed on [7353].

Note: See TracTickets for help on using tickets.
Back to Top