Opened 7 years ago

Closed 7 years ago

#6815 closed (duplicate)

NameError: global name 'view_func' is not defined

Reported by: pigletto Owned by: Mnewman
Component: contrib.admin Version: newforms-admin
Severity: Keywords: view_func
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

File django/contrib/admin/sites.py contains reference to 'view_func' that is never defined. Traceback:

Traceback (most recent call last):
 File "/usr/lib/python2.5/site-packages/django/core/handlers/base.py", line 81, in _real_get_response
 File "/usr/lib/python2.5/site-packages/django/contrib/admin/sites.py", line 115, in root
 File "/usr/lib/python2.5/site-packages/django/contrib/admin/sites.py", line 245, in login

NameError: global name 'view_func' is not defined

Change History (3)

comment:1 Changed 7 years ago by Michael Newman <newmaniese@…>

  • Needs documentation unset
  • Needs tests unset
  • Owner changed from nobody to anonymous
  • Patch needs improvement unset
  • Status changed from new to assigned
  • Triage Stage changed from Unreviewed to Accepted

To be a little more specific on this error and when it occurs while I start on a patch, if a user is logged out and tries to post data to the admin they are asked to login and then this error is raised while handling the post data.

comment:2 Changed 7 years ago by Mnewman

  • Owner changed from anonymous to Mnewman
  • Status changed from assigned to new

comment:3 Changed 7 years ago by brosner

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5999.

Note: See TracTickets for help on using tickets.
Back to Top