Opened 7 years ago

Closed 7 years ago

#6771 closed (duplicate)

ImportError when trying to use newforms-admin with django.contrib.auth

Reported by: esaj Owned by: nobody
Component: Contrib apps Version: newforms-admin
Severity: Keywords: UserCreationForm, newforms-admin
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The following error occurs when trying to use newforms-admin with django.contrib.auth:

Could not import django.contrib.auth.views. Error was: cannot import name UserCreationForm

This import is happening in django.contrib.auth.admin; if I add a try...except around the import to catch the ImportError it fixes it.

This happens when trying to view any page; it must be occurring during the initial loading of urlpatterns but I'm not sure what the fix should be.

Change History (2)

comment:1 Changed 7 years ago by esaj

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

See also #6083.

comment:2 Changed 7 years ago by brosner

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6718.

Note: See TracTickets for help on using tickets.
Back to Top