Code

Opened 6 years ago

Closed 6 years ago

Last modified 3 years ago

#6718 closed (fixed)

ImportError at /admin/logout/

Reported by: Eric B <ebartels@…> Owned by: nobody
Component: Contrib apps Version: newforms-admin
Severity: Keywords: auth importerror logout nfa-blocker
Cc: post@… Triage Stage: Accepted
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: yes
Easy pickings: UI/UX:

Description

I'm getting an ImportError at /admin/logout/

Traceback:
File "/home/mrmelve/dev/python-local/django/core/handlers/base.py" in get_response
  82.                 response = callback(request, *callback_args, **callback_kwargs)
File "/home/mrmelve/dev/python-local/django/contrib/admin/sites.py" in root
  113.             return self.logout(request)
File "/home/mrmelve/dev/python-local/django/contrib/admin/sites.py" in logout
  197.         from django.contrib.auth.views import logout
File "/home/mrmelve/dev/python-local/django/contrib/auth/views.py" in <module>
  1. from django.contrib.auth.forms import AuthenticationForm
File "/home/mrmelve/dev/python-local/django/contrib/auth/forms.py" in <module>
  1. from django.contrib.auth.models import User
File "/home/mrmelve/dev/python-local/django/contrib/auth/models.py" in <module>
  369. from django.contrib.auth import admin
File "/home/mrmelve/dev/python-local/django/contrib/auth/admin.py" in <module>
  1. from django.contrib.auth.forms import UserCreationForm

Exception Type: ImportError at /admin/logout/
Exception Value: cannot import name UserCreationForm

This looks like a circular import problem in contrib.auth.admin.
From the traceback, importing User imports admin which imports UserCreationForm which imports User again.
Oddly, I haven't experienced this error using the development server, but only when running under mod_python. Also, the problem is somewhat intermittent in that sometimes the logout completes without a problem, but most of the time triggers the import error.

I've attached a patch which avoids the problem by moving the import of UserCreationForm from the top level into the add_view method.

Attachments (1)

logout_importerror.diff (716 bytes) - added by Eric B <ebartels@…> 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by Eric B <ebartels@…>

comment:1 Changed 6 years ago by jacob

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 6 years ago by Bela Hausmann <post@…>

  • Cc post@… added

comment:3 Changed 6 years ago by Mnewman

  • Patch needs improvement set

I believe this error is due to an AlreadyRegistered exception and it will be fixed when that is handled differently. That being said if it is the AlreadyRegistered exception, this patch is really not the way to fix it. Also, I am only able to duplicate this in mod_python; in the runserver environment it doesn't seem to through the error. I think that this error and some other odd AlreadyRegistered errors are due to the way mod_python handles imports.

comment:4 Changed 6 years ago by mariarchi

It also happens to me when I'm trying to log in (mod_python, worker mpm).
Also, why this ticket is not marked as nfa-blocker?

comment:5 Changed 6 years ago by mrts

  • Keywords nfa-blocker added

Marking as nfa-blocker. This clearly needs to be fixed one way or other before nfa can be merged.

comment:6 Changed 6 years ago by garcia_marc

  • milestone set to 1.0 alpha

comment:7 Changed 6 years ago by brosner

  • Resolution set to fixed
  • Status changed from new to closed

(In [7671]) newforms-admin: Fixed #6718 -- Removed a circular import in contrib/auth/admin.py. Thanks Eric B.

comment:8 Changed 3 years ago by jacob

  • milestone 1.0 alpha deleted

Milestone 1.0 alpha deleted

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.