Opened 7 years ago

Closed 7 years ago

#6605 closed (duplicate)

PostgresSQL v8.3 Non-character data types are no longer automatically cast to TEXT

Reported by: sector119 <sector119@…> Owned by: nobody
Component: Database layer (models, ORM) Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Due to subject it's not longer possible to use iexact, icontains,
istartswith, iendswith in lookup type with int4, int8, ...
filed types!

It doesn't make a lot of sense to do partial string matches against non-strings, but sometimes it does.
For example, many people use integer fields for primary key values, but that integers not often just "digets", sometimes they are "codes" and someone need to do partial string matches against non-strings, integers (digits), in our case.

Change History (2)

comment:1 Changed 7 years ago by mtredinnick

  • Keywords qs-rf added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 7 years ago by mtredinnick

  • Component changed from Uncategorized to Database wrapper
  • Keywords qs-rf removed
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #6523.

Note: See TracTickets for help on using tickets.
Back to Top