Code

Opened 6 years ago

Closed 5 years ago

#6588 closed (worksforme)

Admin interface doesn't allow to use dots in usernames

Reported by: anonymous Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords: nfa-someday
Cc: bronger@… Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

It's common practice to use usernames with dots (for example john.smith), but such usernames couldn't be entered in django admin interface.

Attachments (3)

allow_dots_in_usernames.patch (2.8 KB) - added by anonymous 6 years ago.
allow_dots_in_usernames-1.patch.txt (2.8 KB) - added by bronger 6 years ago.
allow_dots_in_usernames-1.patch (2.8 KB) - added by bronger 6 years ago.

Download all attachments as: .zip

Change History (13)

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by Simon Greenhill <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:2 Changed 6 years ago by Simon Greenhill <dev@…>

  • Version changed from SVN to newforms-admin

comment:3 Changed 6 years ago by jacob

  • Triage Stage changed from Ready for checkin to Design decision needed

comment:4 Changed 6 years ago by alexander.hungenberg@…

I would really need this feature for copying about 1200 LDAP Users...
Technically this seems to be no problem :)

comment:5 Changed 6 years ago by anonymous

Minor edit needed in patch.

In django/contrib/auth/models.py, shouldn't the last sentence of line 131 actually read "Alphanumeric characters only (letters, digits, periods and underscores)." rather than "Alphanumeric characters only (letters, digits and underscores)."?

comment:6 Changed 6 years ago by Karen Tracey <kmtracey@…>

  • Keywords nfa-someday added

This restriction exists in current admin as well, should not block nfa merge.

comment:7 Changed 6 years ago by Torsten Bronger <bronger@…>

  • Cc bronger@… added

comment:8 Changed 6 years ago by bronger

  • Patch needs improvement set

The new regex in the patch needs a trailing $.

Changed 6 years ago by bronger

Changed 6 years ago by bronger

comment:9 Changed 6 years ago by bronger

  • Patch needs improvement unset

I appended the "$" to the regexp, and fixed to minor errors in the docstrings of the patch.

comment:10 Changed 5 years ago by dc

  • Resolution set to worksforme
  • Status changed from new to closed

Duplicate of #5786

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.