Opened 8 years ago

Closed 5 years ago

#6553 closed (duplicate)

Form Errorlist UL displays instead of field.label

Reported by: dave@… Owned by: nobody
Component: Forms Version: master
Severity: Keywords: form fields errors errorlist label
Cc: ubernostrum Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When one wants to display all form errors together on a page with i.e. {{ myform.errors }} the fields' name is shown together with the error.

<ul class="errorlist">
    <li>fieldNAME e.g. "user_email"
        <ul class="errorlist">
            <li>field error</li>

Mostly though, one would want to display the fields' label:

<ul class="errorlist">
    <li>field LABEL: e.g. "Your e-mail:"
        <ul class="errorlist">
            <li>field error</li>

One 'fix' is to manually 'super' the ful_clean() method on a Form class, but this seems awkward. I cannot think of a situation where I would prefer the in the presentation of form errors.

Should the full_clean() method of the BaseForm class be fixed to display the fields' label?

Change History (3)

comment:1 Changed 8 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 8 years ago by stugots

  • Cc ubernostrum added

Is this a duplicate of #6705, which was marked invalid?

comment:3 Changed 5 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6705

Note: See TracTickets for help on using tickets.
Back to Top