request.get_host() should be request.host
|Reported by:||eratothene||Owned by:||nobody|
|Cc:||Triage Stage:||Design decision needed|
|Has patch:||no||Needs documentation:||no|
|Needs tests:||no||Patch needs improvement:||no|
Looking the HttpRequest class, I see all properties has plain name like: request.method, request.user, request.path. No methods that have get_smth() name, hence for holding have convention I propose to rename request.get_host() with request.host. As request.get_host() is not documented, there is no backward compatibilty problem, but the depreciated get_host() can remain for some time.
Also request.get_host() is not documented yet. I can do this as well.
Let's agree on idea and I will make patch.
Change History (10)
comment:1 Changed 9 years ago by
|Patch needs improvement:||unset|