Code

Opened 6 years ago

Closed 6 years ago

#6111 closed (duplicate)

Wrong length of database columns 'name', 'codename' for 'auth_permission' table.

Reported by: Ivan Markeyev <markeev@…> Owned by: nobody
Component: Uncategorized Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

As i understand, 'name' and 'codename' columns for 'auth_permission'
table generated automatically from object class name. 'name' are
consist 'Can add+[class name]', 'codename' - add_+[class name].
So, they should be the same length or 'name' should be larger then
'codename'.

In postgresql they are varchar(50) - 'name' and varchar(100) -
'codename'.

Sorry for my english.

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by guettli

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed
  • Triage Stage changed from Unreviewed to Design decision needed

Duplicate of #4748

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.