Code

Opened 7 years ago

Closed 7 years ago

#6104 closed (duplicate)

admin ManyToMany widget: js broken for 'add another' popup

Reported by: Steven Armstrong Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In RelatedObjectLookups.js dismissRelatedLookupPopup get's passed an
integer which is then run through html_unescape.

html_unescape errors out while trying to call a .replace method on the int.

The effect of this is that the change-form popup stays open and the value in the select element doesn't get updated.

The attached patch fixes that by ensuring the arguments of html_unescape are string.

Attachments (1)

RelatedObjectLookups.js.patch (607 bytes) - added by Steven Armstrong 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Steven Armstrong

comment:1 Changed 7 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6100.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.