Code

Opened 6 years ago

Closed 6 years ago

#5983 closed (fixed)

iriencode doesn't respect safe strings

Reported by: Antonis Christofides <anthony@…> Owned by: nobody
Component: Template system Version: master
Severity: Keywords: auto-escaping
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

This happens probably since autoescape. Steps to reproduce:

  1. In a model, use the following:
        class Admin:
            list_filter = ['column_a', 'column_b']
    

and you'll have two filters shown in the admin.

  1. Choose something other than "All" in the first filter
  1. Hover the mouse over something other than "All" in the second filter and look at the url.

Result: It will have a "&amp;" somewhere, when it should only have a "&". It doesn't work if you click it, of course.

See also #5976 for a related bug.

Attachments (1)

safe_iriencode.diff (1.6 KB) - added by SmileyChris 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

I narrowed it down to django/contrib/admin/templates/admin/filter.html - choice.querystring is SafeData, but iriencode doesn't respect that and it gets re-escaped.

Solution seems to be marking the iriencode filter with is_safe, since it doesn't introduce dangerous characters - so a safe string in means a safe string out.

comment:2 Changed 6 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Accepted

(oh, and I can confirm this buggy behaviour)

Changed 6 years ago by SmileyChris

comment:3 Changed 6 years ago by SmileyChris

  • Component changed from Admin interface to Template system
  • Has patch set
  • Keywords auto-escaping added
  • Summary changed from Admin escapes ampersands in URLs when joining filters to iriencode doesn't respect safe strings
  • Triage Stage changed from Accepted to Ready for checkin

Changing the topic to reflect the real cause of the issue.

comment:4 Changed 6 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [6706]) Fixed #5983 -- Made iriencode filter respect safe strings. Patch from
SmileyChris.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.