Code

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5976 closed (fixed)

Admin escapes non-breaking spaces for empty fields in change list

Reported by: nickl Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The admin change list displays   in all empty fields since autoescape has landed, since a non-breaking space is returned but not marked as safe.

Attachments (1)

5976.patch (754 bytes) - added by nickl 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by nickl

comment:1 Changed 6 years ago by nickl

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

comment:2 Changed 6 years ago by SmileyChris

  • Triage Stage changed from Unreviewed to Ready for checkin

Gosh, I just make a ticket 20 minutes too late :)

comment:3 Changed 6 years ago by nickl

I noticed it on Friday but didn't have a chance to take a look at the cause until today. Sorry ;-)

comment:4 Changed 6 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [6705]) Fixed #5976 -- Handle auto-escaping correctly for empty columns in admin change
view.

comment:5 Changed 6 years ago by toke

Same Bug in newforms admin.
Same Patch also works with Newforms-Admin branch [6783].

comment:6 follow-up: Changed 6 years ago by toke

Added another Ticket for newforms admin [6078]

comment:7 in reply to: ↑ 6 Changed 6 years ago by toke

Replying to toke:

Added another Ticket for newforms admin [6078]

Sorry, wrong Syntax
Erm #6078

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.