Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5769 closed (duplicate)

djangoproject.com shows quite a few HTML and CSS validation errors

Reported by: Dinu Gherman <gherman@…> Owned by: nobody
Component: *.djangoproject.com Version:
Severity: Keywords: HTML CSS valdation errors
Cc: Triage Stage: Ready for checkin
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I've written a Python script wrapping the W3C HTML and CSS validators
(using http://validator.w3.org and http://jigsaw.w3.org/css-validator).
Running it over the main Django website and those of some competitors
gives some interesting data below. Apparently only Plone.org contains
flawless HTML code. (Unfortunately, Trac doesn't accept too many URLs
in a posting, so I had to remove most of the HTTP protocols in the
tables below.)

$ py25 checkML.py --html

LengthErrorsErrs./MBURL: http://validator.w3.org/check?uri=http://
================================================================
19705 9 478www.djangoproject.com
19877 9 474www.djangoproject.com/documentation
19986 9 472www.djangoproject.com/documentation/db-api
19819 9 476www.djangoproject.com/download
68529 36 550www.djangoproject.com/weblog
19935 9 473www.djangoproject.com/weblog/2007/jul
78031 36 483www.djangoproject.com/community
20319 8 412code.djangoproject.com
20359 8 412code.djangoproject.com/wiki
15096 0 0code.djangoproject.com/wiki/BackwardsIncompatibleChanges
14380 0 0www.djangobook.com
14941 0 0www.djangosites.org
441094 202 480www.djangosnippets.com
26328 10 398www.turbogears.org
20242 8 414www.rubyonrails.org
28550 20 734www.zope.org
19611 8 427www.zope.com
14816 0 0www.plone.org
22453 7 326www.typo3.com
151873 94 649www.php.com
27756 8 302www.drupal.com

$ py25 checkML.py --css

LengthErrorsErrs./MBURL: http://jigsaw.w3.org/css-validator/validator?uri=http://
177683 3 17www.djangoproject.com
175372 3 17www.djangoproject.com/documentation
175393 3 17www.djangoproject.com/documentation/db-api
175357 3 17www.djangoproject.com/download
175351 3 17www.djangoproject.com/weblog
175378 3 17www.djangoproject.com/weblog/2007/jul
175360 3 17www.djangoproject.com/community
193085 2 10code.djangoproject.com
193120 2 10code.djangoproject.com/wiki
193323 2 10code.djangoproject.com/wiki/BackwardsIncompatibleChanges
84995 10 123www.djangobook.com
64005 4 65www.djangosites.org
65280 1 16www.djangosnippets.com
46878 2 44www.turbogears.org
71642 4 58www.rubyonrails.org
188729 7 38www.zope.org
67528 0 0www.zope.com
920 0 0www.plone.org
66052 0 0www.typo3.com
27125 0 0www.php.com
3794 0 0www.drupal.com

If djangoproject.com is created with Django it would be a plus to
be able to say "Look Ma, it has no errors!" I'm pretty sure it's only
some template issues...

Attachments (2)

base-patch.html (377 bytes) - added by Dinu Gherman <gherman@…> 8 years ago.
adding missing tag and end slash in footer
base-patch-u.html (864 bytes) - added by Dinu Gherman <gherman@…> 8 years ago.
patch (now with diff -u) for adding a missing tag and a missing end slash

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by durdinator

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Would you be able to track some of these down and make some patches?

comment:2 Changed 8 years ago by durdinator

  • Triage Stage changed from Unreviewed to Accepted

comment:3 Changed 8 years ago by Dinu Gherman <gherman@…>

  • Version SVN deleted

It's pretty simple to track down the errors if you go to the output
pages of the respective validator, e.g.
http://validator.w3.org/check?uri=http://www.djangoproject.com
which will give details about each error.
If you go to the previous link you can see that quite some errors
seem to have their origin in the footer part of this page (and
hence, probably other pages as well).

It's harder for me to test any resulting HTML patches than for
somebody with direct access to the website.

comment:4 Changed 8 years ago by SmileyChris

Dinu, you (or someone else who wants to) should be able to write the patches by checking out the website source from svn and making the changes that will fix it.

Changed 8 years ago by Dinu Gherman <gherman@…>

adding missing tag and end slash in footer

comment:5 Changed 8 years ago by Dinu Gherman <gherman@…>

Well, ok. Here is a first tiny patch, named base-patch.html, to djangoproject.com/django_website/templates/base.html that should help. Basically it adds a missing tag and a missing end slash. There's probably more, but let's see how this one makes a difference...

comment:6 follow-up: Changed 8 years ago by mtredinnick

  • Patch needs improvement set

Please create patches with "diff -u" (or "svn diff -u", even) and from the root of the checked out tree. That way, the patch will be easier to read and the file that it applies to will be clear from the patch itself.

Changed 8 years ago by Dinu Gherman <gherman@…>

patch (now with diff -u) for adding a missing tag and a missing end slash

comment:7 in reply to: ↑ 6 Changed 8 years ago by Dinu Gherman <gherman@…>

Replying to mtredinnick:

Please create patches with "diff -u" (or "svn diff -u", even) and from the root of the checked out tree. That way, the patch will be easier to read and the file that it applies to will be clear from the patch itself.

Done.

comment:8 Changed 8 years ago by Dinu Gherman <gherman@…>

  • Patch needs improvement unset
  • Triage Stage changed from Accepted to Ready for checkin

I guess I need to change the status to "Ready for checkin", so that's what I'm doing.

comment:9 follow-up: Changed 8 years ago by Dinu Gherman <gherman@…>

Is there anything else I can do to make this change happen?

comment:10 in reply to: ↑ 9 ; follow-up: Changed 8 years ago by garcia_marc

Replying to Dinu Gherman <gherman@darwin.in-berlin.de>:

Is there anything else I can do to make this change happen?

I don't know if this ticket is more extensive than #5644 (that was ready for checkin), but it looks like a duplication.

comment:11 in reply to: ↑ 10 Changed 8 years ago by Dinu Gherman <gherman@…>

Replying to garcia_marc:

I don't know if this ticket is more extensive than #5644 (that was ready for checkin), but it looks like a duplication.

Sorry, I didn't notice #5644 when posting my ticket. In fact, I also reported a missing </div>. In any case, it should probably not take four weeks to fix that, should it?

comment:12 Changed 8 years ago by anonymous

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a dupe of #5644

Dinu - if there are any changes which you've made which are not reflected in the patch there, please submit them over in that ticket.

And regarding the time it's taking - it's not super high priority and the developers have all been rather busy, but don't worry it'll get done ;)

comment:13 Changed 8 years ago by SmileyChris

(that was me)

Note: See TracTickets for help on using tickets.
Back to Top