Code

Opened 7 years ago

Closed 7 years ago

#5739 closed (duplicate)

Image and File Fields edited inline do not exhibit 'expected' behaviour

Reported by: Lllama Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords: imagefield admin error
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When inline editing a model with an ImageField the admin application will 'incorrectly' display error messages (for my version of incorrectly). If the parent model already has associated images and the user attempts to upload a new one then an error is produced on the existing child field, stating that a file is required, even though one is already present.

I assume that this is due to the ImageField being validated using only the POST data, when a check should be performed to see whether an image already exists. Under the old core fields method this allowed an instance to be deleted, but since we now have delete buttons I don't see why the additional check can't be made.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by brosner

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5721.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.