Code

Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#5673 closed (wontfix)

[enhancement] Admin interface only sort by the first ordering field in Meta class (in models)

Reported by: DXpublica@… Owned by: nobody
Component: contrib.admin Version: master
Severity: Keywords: ordering Meta multiple-ordering
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

In any model, if we have multiple ordering:

class Meta:
      ordering = ['one_field', 'another_field']

admin mode only sort the model by the first field ('one_field' in example) and not only by all specified fields, as it were the right thing

It's not a bug (see discussion: http://groups.google.com/group/django-developers/browse_thread/thread/c74afae800fda0b9/7c744053660b8a82#7c744053660b8a82) but it could be an enhancement

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to wontfix
  • Status changed from new to closed

Given the difficulties in making this work sensibly in the UI (which is the reason for the current behaviour), I'm going to close this ticket for now. If/when somebody comes up with code that implements the feature, they can open a ticket and attach their patch. Until then, though, having an open ticket about such an item is only going to fill up the list of open tickets. It's not something we're likely to work on as a priority.

comment:2 Changed 7 years ago by anonymous

You could mark as "open" and "another branch". With that, it does not annoy us and we remember it

Thansks,
Xan.

comment:3 Changed 3 years ago by lukeplant

#11868 is a ticket which implements this.

comment:4 Changed 3 years ago by samjacoby

Related to #4926, I think.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.