Code

Opened 7 years ago

Closed 7 years ago

#5546 closed (fixed)

Split newforms tests

Reported by: leosoto <leo.soto@…> Owned by: nobody
Component: Forms Version: master
Severity: Keywords: jython
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

tests/regressiontests/forms/{tests.py,localflavor.py} are too big for Jython, where exists a limit of 32KB for the length of string literals.

And, IMO, they are too big for humans too.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by leosoto <leo.soto@…>

  • Has patch set
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

[The patch size is more than 256KBytes, so trac don't let me attach it here.]

http://www.leosoto.com/split_newforms_tests2.patch splits localflavors tests into its own directory (one file per flavor) and form tests into four files: widgets, fields, forms and extras.

As widgets.py and forms.py strings were still above 32KBytes, and I didn't knew a good criteria to split them more, string concatenation was used to avoid problems with Jython.

comment:2 Changed 7 years ago by jacob

  • Resolution set to fixed
  • Status changed from new to closed

(In [6379]) Fixed #5546: split form unit tests into manageable chunks. This isn't a perfect fix since the chunks aren't yet autodiscovered, but that shouldn't prevent checking this in. Thanks, Leo Soto.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.