Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#5545 closed (duplicate)

Changeset 6342 broke newforms-admin change/add functionality

Reported by: lukas einfachkaffee de Owned by: nobody
Component: contrib.admin Version: newforms-admin
Severity: Keywords:
Cc: lukas@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


I don't know what exactly caused it, but I 'nailed' it down to changeset 6342 - since than, I can't add nor change Objects in newforms-admin anymore. Even with a model as simple as

class ConfigScheme(models.Model):
    Defines a Scheme for UID, GID, Maildir of Domains
    name = models.CharField('ConfigScheme Name', maxlength=200)
    owner = models.ForeignKey(DjangoUser)
    maildirprefix = models.CharField('Maildir Prefix', maxlength=300)
    uid = models.IntegerField('vMail UID')
    gid = models.IntegerField('vMail GID')

    def __unicode__(self):

Where DjangoUser is django's user model, I get a TypeError:

Traceback (most recent call last):
File "/srv/managedApps/django_newforms-admin/django/core/handlers/" in _real_get_response
  81. response = callback(request, *callback_args, **callback_kwargs)
File "/srv/managedApps/django_newforms-admin/django/contrib/admin/" in root
  136. return self.model_page(request, *url.split('/', 2))
File "/srv/managedApps/django_newforms-admin/django/contrib/admin/" in model_page
  153. return admin_obj(request, rest_of_url)
File "/srv/managedApps/django_newforms-admin/django/contrib/admin/" in __call__
  251. return self.change_view(request, unquote(url))
File "/srv/managedApps/django_newforms-admin/django/contrib/admin/" in change_view
  535. form = ModelForm()
File "/srv/managedApps/django_newforms-admin/django/newforms/" in __init__
  81. self.fields = self.base_fields.copy()
File "/srv/managedApps/django_newforms-admin/django/newforms/" in copy
  34. return SortedDictFromList([(k, copy.deepcopy(v)) for k, v in self.items()])
File "/srv/managedApps/django_newforms-admin/django/newforms/" in __deepcopy__
  107. result.widget = copy.deepcopy(self.widget, memo)

  TypeError at /mokel2/admin/mail/configscheme/1/
  function() takes at least 2 arguments (0 given)

I'd happily provide more info if needed.

Change History (2)

comment:1 Changed 8 years ago by jkocherhans

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Please svn up to r6341. ForeignKeys and ManyToManyFields are broken in the admin after that revision. This is a duplicate of #5505. I'm not going to roll back the branch for this one. Sorry, welcome to the bleeding edge ;) The are a few ways to fix it, but it should be fixed in trunk.

comment:2 Changed 8 years ago by lukas@…

Thank you for pointing me to the root of the problem, I didn't find #5505 before. And I happily live with that risk of the bleeding edge again :)

Note: See TracTickets for help on using tickets.
Back to Top