Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#5299 closed (fixed)

mod_python documentation issues

Reported by: jdunck Owned by: DavidReynolds
Component: Documentation Version: master
Severity: Keywords:
Cc: Graham.Dumpleton@… Triage Stage: Accepted
Has patch: no Needs documentation: yes
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Posting for Graham Dumpleton, since his attempt was rejected as spam:

In #5280 the issue of some
mistakes in latest changes to mod_python documentation have been made.
In reviewing associated #4296 and
the changes, I note that the issues I brought up in mod_python
documentation and referenced in the ticket were not addressed. Ie., as
described in:

http://groups.google.com/group/django-users/browse_frm/thread/24deb095a2b2e450/1c982558d464017a

The problem is that people who use development server (and later move
to mod_python), can find their application do not work as they have
inadvertently used the fact that it is possible to list module paths
in urls.py or perform imports in subdirectories that don't import via
the top level site name. Instead they do them relative to the site
name instead.

For this to work when moved to mod_python they must also add the
actual site directory to PythonPath in addition to the parent
directory. I still don't see this as being documented

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Simon G. <dev@…>

  • Needs documentation set
  • Triage Stage changed from Unreviewed to Accepted

Please try to write something that does please everyone.

comment:2 Changed 7 years ago by DavidReynolds

  • Owner changed from nobody to DavidReynolds

comment:3 Changed 7 years ago by DavidReynolds

  • Resolution set to fixed
  • Status changed from new to closed

Seems to be already addressed.

comment:4 Changed 7 years ago by mtredinnick

To clarify the above comment, we already mention explicitly that the parent of any directory you import from must be in the Python path. That covers the case when somebody has a project directory and is import relative to that (since it's the parent of what they are importing).

What else do you think needs adding?

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.