Code

Opened 7 years ago

Closed 7 years ago

#5238 closed (duplicate)

Add ability to intialize form fields with model field default values.

Reported by: Kevin Menard Owned by: adrian
Component: Forms Version: newforms-admin
Severity: Keywords:
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using the old admin, form fields are populated with the model field default values. With the move to newforms, this ceased to be the case. It would be really nice if the old behavior could be reinstated. In particular, it would be nice if the form field initial values were set to the model field default values.

I've attached a simple patch that provides this behavior.

Attachments (1)

initial-default.diff (965 bytes) - added by Kevin Menard 7 years ago.

Download all attachments as: .zip

Change History (2)

Changed 7 years ago by Kevin Menard

comment:1 Changed 7 years ago by adrian

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4967.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.