Opened 8 years ago

Closed 7 years ago

#5094 closed (duplicate)

[newforsm-admin] (Feature Proposal) add something like queryset_related

Reported by: apollo13 Owned by: adrian
Component: contrib.admin Version: newforms-admin
Severity: Keywords: related objects limit queryset
Cc: django@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Using queryset_change we can hide some objects on the change_list view (eg. according to some permissions, or display only the users objects). But if another Model uses a Foreignkey to this model it displays all entries. I think it would be usefull to display only the limited queryset (eg. adding a queryset_related method, to accomplish that).

I don't know if this is already possible, maybe I missed something.
I hope it is okay to post this in trac, but for the next time should I start a thread on the groups or post here?

Change History (1)

comment:1 Changed 7 years ago by jkocherhans

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

I'm pretty sure this is a duplicate of #3987, which has some proposed solutions. Please re-open with an explanation of the difference if you disagree. It's fine to post feature requests here, but you'll get a better response if you post to django-dev.

Note: See TracTickets for help on using tickets.
Back to Top