Opened 8 years ago

Closed 8 years ago

#4749 closed (duplicate)

Title filter error with non us-ascii chars

Reported by: marc.garcia@… Owned by: adrian
Component: Template system Version: master
Severity: Keywords: filter title character set unicode-branch
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:


When applying title filter to a word with non us-ascii characters, wrong results are returned. Upper case is set after this characters inside the word.

For example,
{% filter title %}discothèque{% endfilter %}
returns DiscothèQue
expected Discothèque

Attachments (1) (448 bytes) - added by marc.garcia@… 8 years ago.
Possible fix to this bug (to be reviewed)

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by marc.garcia@…

Possible fix to this bug (to be reviewed)

comment:1 Changed 8 years ago by mtredinnick

(In [5591]) unicode: Added a test to ensure that we title-case non-ASCII strings properly.
Refs #4749.

comment:2 Changed 8 years ago by mtredinnick

  • Keywords unicode-branch added
  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

There are lots of little problems like this with non-ASCII data on trunk at the moment and we're working on fixing things holistically rather than with individual changes (on the Unicode branch). This is already handled properly in the Unicode branch, so I'll close this ticket once that branch is merged into trunk.

comment:3 Changed 8 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Turns out this is a dupe of #2391 and that's already on the to-close list after the merge.

Note: See TracTickets for help on using tickets.
Back to Top