Opened 8 years ago

Closed 8 years ago

#4708 closed (invalid) dbshell problem on Windows

Reported by: anonymous Owned by: adrian
Component: Core (Management commands) Version: master
Severity: Keywords: dbshell
Cc: yml.nospam@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:



I have a problem on my laptop when I run this command: " runserver" I get this error message:

C:\yml\_myScript_\dj_things\web_development\workspace\dj_project> dbshell
Traceback (most recent call last):

File "C:\yml\_myScript_\dj_things\web_development\workspace\dj_project\", line 11, in <module>


File "C:\yml\_myScript_\dj_things\web_development\svn_views\django_src\unicode\django\core\", line 1736,

in execute_manager

execute_from_command_line(action_mapping, argv)

File "C:\yml\_myScript_\dj_things\web_development\svn_views\django_src\unicode\django\core\", line 1631,

in execute_from_command_line


File "C:\yml\_myScript_\dj_things\web_development\svn_views\django_src\unicode\django\core\", line 1330,

in dbshell


File "C:\yml\_myScript_\dj_things\web_development\svn_views\django_src\unicode\django\db\", line 28, in <la


runshell = lambda: import('django.db.backends.%s.client' % settings.DATABASE_ENGINE, {}, {}, []).runshell()

File "C:\yml\_myScript_\dj_things\web_development\svn_views\django_src\unicode\django\db\backends\mysql\", li

ne 27, in runshell

os.execvp('mysql', args)

File "C:\install\Python25\lib\", line 354, in execvp

_execvpe(file, args)

File "C:\install\Python25\lib\", line 392, in _execvpe

func(fullname, *argrest)

OSError: [Errno 2] No such file or directory

Also the rest of the framework is working just fine. I was running from the trunk on windows with python 2.5. Then I try to use the unicode branch same result. Then I have updated from python 2.5 to 2.5.1 same result.

Thank you for your help

Change History (6)

comment:1 Changed 8 years ago by Paul Bx <pb@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Summary changed from dbshell is broken to dbshell problem on Windows

comment:2 Changed 8 years ago by Ramiro Morales

It seems you are using dj_project as your Django project name. This name should be a valid Python module name (see the Note here and dj_project isn't.

comment:3 Changed 8 years ago by Ramiro Morales

Disregard my previous post (I remember having some problems when using _ in a project/app name that I solved renaming them; but now I'm testing things with a dummy project and if works Ok).

Reading the complete traceback (what I shold have done first :) it seems you don't have the mysql.exe (does such thing exist?) MySQL command line client accesible via the PATH envvar.

comment:4 Changed 8 years ago by anonymous

I finally manage to test this on a Linux box and it is working fine there. I am assuming that this bug is a windows only or it is linked to the configuration of this particular computer.

comment:5 Changed 8 years ago by Ramiro Morales

So, can this ticket be closed?

comment:6 Changed 8 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

I confirm that this issue was due to the fact that mysql.exe was not in my path. I set this ticket as invalid.
Thank you for your help

Note: See TracTickets for help on using tickets.
Back to Top