Code

Opened 7 years ago

Closed 7 years ago

#4665 closed (duplicate)

Serving media files in dev mode conflicts if you name the URL media

Reported by: anonymous Owned by: adrian
Component: Contrib apps Version: master
Severity: Keywords: media static serve dev
Cc: Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The example>

(r'site_media/(?P<path>.*)$', 'django.views.static.serve', {'document_root': '/path/to/media', 'show_indexes': True}),

works just fine, but if you happen to change the site_media prefix to media, then it will conflict with Djangos own internal media serving for the admin add on and wont work.

Attachments (0)

Change History (1)

comment:1 Changed 7 years ago by SmileyChris

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #2891

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.