Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4477 closed (fixed)

[newforms-admin] Models on index.html aren't grouped by app_label

Reported by: Honza Král <Honza.Kral@…> Owned by: adrian
Component: contrib.admin Version: other branch
Severity: Keywords: newforms admin app_label
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

When I register several models from one application to django.contrib.admin.site they don't appear in the same table on admin's index page. It looks like this:

+--------------------------+
| MyApp                    |
+--------------------------+
| MyModel1                 |
+--------------------------+

+--------------------------+
| OtherApp                 |
+--------------------------+
| NotMyModel               |
+--------------------------+

+--------------------------+
| MyApp                    |
+--------------------------+
| MyModel2                 |
+--------------------------+

where it should imho be:

+--------------------------+
| MyApp                    |
+--------------------------+
| MyModel1                 |
| MyModel2                 |
+--------------------------+

+--------------------------+
| OtherApp                 |
+--------------------------+
| NotMyModel               |
+--------------------------+

Attachments (1)

newforms-admin-5427-app_grouping.diff (2.1 KB) - added by Honza Král <Honza.Kral@…> 7 years ago.
Patch correcting the bug

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Honza Král <Honza.Kral@…>

Patch correcting the bug

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #4258 (which also has a patch).

comment:2 Changed 7 years ago by adrian

  • Resolution changed from duplicate to fixed

(In [5441]) newforms-admin: Fixed #4258 and #4477 -- Changed admin index page to group by applications, and alphabetized things. Thanks to Matthias Pronk and Honza Kral for the patches; I ended up using a hybrid of both

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.