Opened 8 years ago

Closed 8 years ago

#4391 closed (invalid)

data should not be stored in cleaned_data until it is fully cleaned

Reported by: Gary Wilson <gary.wilson@…> Owned by: adrian
Component: Forms Version: master
Severity: Keywords:
Cc: Triage Stage: Design decision needed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Currently, the value returned from a field's clean method is stored in cleaned_data even though it hasn't passed through clean_<field> yet.

If #3896 is implemented, the fix for this is simple.

Change History (2)

comment:1 Changed 8 years ago by Gary Wilson <gary.wilson@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Design decision needed

comment:2 Changed 8 years ago by mtredinnick

  • Resolution set to invalid
  • Status changed from new to closed

This isn't really a bug. It's an internal implementation detail, since we immediately call the fieldname-specific clean method afterwards. Fixing #4390 fixes the root cause here.

Note: See TracTickets for help on using tickets.
Back to Top