Opened 8 years ago

Closed 8 years ago

#4367 closed (fixed)

[unicode] debug.py: non ascii data in local vars

Reported by: Thomas Güttler <hv@…> Owned by: mtredinnick
Component: Internationalization Version: other branch
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

Hi,

if there are non ascii values in the local vars, the
debug template fails. Here is a patch.

Attachments (1)

debug_py.diff (1.6 KB) - added by Thomas Güttler <hv@…> 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by Thomas Güttler <hv@…>

comment:1 Changed 8 years ago by mtredinnick

  • Component changed from Uncategorized to Internationalization
  • Needs documentation unset
  • Needs tests unset
  • Owner changed from jacob to mtredinnick
  • Patch needs improvement unset
  • Summary changed from unicode: debug.py: non ascii data in local vars to [unicode] debug.py: non ascii data in local vars
  • Triage Stage changed from Unreviewed to Accepted
  • Version changed from SVN to other branch

I don't like this patch. Having smart_unicode or anything like that leak up to the template level shouldn't be necessary. It's fixing the symptom, rather than the cause of the problem. I'll fix it some other way. Thanks for the report.

comment:2 Changed 8 years ago by mtredinnick

My apologies... that last comment sounds a lot more ungrateful than it was meant to be. I really do appreciate the bug report and the fact that you've posted an attempted fix (for a start, it points to one of the places where the problem is visible).

comment:3 Changed 8 years ago by mtredinnick

  • Resolution set to fixed
  • Status changed from new to closed

(In [5323]) unicode: Fixed #4367 -- Fixed a problem when trying to display some
legitimately non-unicode, non-UTF-8 data. The workaround is probably a bit
broad, but it shouldn't hurt in any unintended way I can think of.

Note: See TracTickets for help on using tickets.
Back to Top