Code

Opened 7 years ago

Closed 7 years ago

#4153 closed (duplicate)

testing is coupled to models.py

Reported by: thebanana Owned by: adrian
Component: Testing framework Version: master
Severity: Keywords:
Cc: Triage Stage: Accepted
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The default TESTRUNNER will not run tests in an app that does not have a models.py module. I'm not sure if this is by design (although I'd like to see it try to run the tests anyway). Regardless, the documentation should reflect this since it is the current behaviour.

The use-case for having the TESTRUNNER proceed with tests even without a models.py is when you have Django serving up a site whose models all reside in other libraries (e.g. extensive data model library for legacy system). We tout Django as being flexible enough to run without using the Django ORM - testing should be the same.

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by Simon G. <dev@…>

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Accepted

comment:2 Changed 7 years ago by mtredinnick

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like the same root cause as #3310. Closing as a dupe.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.