Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3899 closed (duplicate)

Building RPM fails for 0.96 (python setup.py bdist_rpm)

Reported by: rich@… Owned by: adrian
Component: Core (Other) Version: 0.96
Severity: Keywords: setup
Cc: Triage Stage: Unreviewed
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

There seems to be a mismatch between the version number generated by the setup.py file and the one it should be using. This causes python setup.py bdist_rpm to fail. I've attached a patch that fixes the problem.

Attachments (1)

fix-setup-version-info.patch (122 bytes) - added by rich@… 7 years ago.
Patch to fix setup bdist_rpm target

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by rich@…

Patch to fix setup bdist_rpm target

comment:1 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of the outstanding issue of #3338.

comment:2 Changed 7 years ago by mtredinnick

By the way, there are two problems with this patch:

  1. It doesn't tell us which file to patch (although I could work it out, because I know the problem you are trying to solve). In future, please generate patches from the top of the tree so that it includes the full path information. And use the "-u" option to get a unifed diff, because it's a bit shorter in most cases.
  2. It tries to fix the problem by making the real version number a bit less readable (humans are more used to reading dashes in strings than underscores). The fix has to be in the rpm package number generation, not by changing Django's version number to something that reads less like a nomrmal number string. That is why #3338 is still open.

comment:3 Changed 7 years ago by mtredinnick

My apologies... your patch does indeed try to fix the right area if it is meant to applied to setup.py. Still not quite right, though and a dupe of #3338, but I didn't want to leave the impression it was totally ridiculous.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.