Code

Opened 7 years ago

Closed 7 years ago

#3780 closed (fixed)

document newforms fields

Reported by: SmileyChris Owned by: jacob
Component: Documentation Version: master
Severity: Keywords:
Cc: Triage Stage: Ready for checkin
Has patch: yes Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

I thought I'd make an initial attempt to document all of the newforms Fields to get the ball rolling.

Attachments (2)

newforms_field_list.patch (7.4 KB) - added by SmileyChris 7 years ago.
newforms_field_list.2.patch (7.4 KB) - added by Marc Fargas <telenieko@…> 7 years ago.
corrected docs.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by SmileyChris

comment:1 Changed 7 years ago by anonymous

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset

Hey, you seem to have EmailField used twice.

comment:2 Changed 7 years ago by Marc Fargas <telenieko@…>

  • Patch needs improvement set

The last EmailField is and URLField :)

Changed 7 years ago by Marc Fargas <telenieko@…>

corrected docs.

comment:3 Changed 7 years ago by Marc Fargas <telenieko@…>

  • Patch needs improvement unset
  • Triage Stage changed from Unreviewed to Ready for checkin

comment:4 follow-up: Changed 7 years ago by SmileyChris

Thanks Marc. Damn you ctrl-c!

comment:5 in reply to: ↑ 4 Changed 7 years ago by Marc Fargas <telenieko@…>

Replying to SmileyChris:

Thanks Marc. Damn you ctrl-c!

Well.. it was a bit more advanced than that!! wget <patch> && patch -p0 < patch [changed 5 letters]... svn diff > patch
ctrl-c is for Word, not for vim :))

comment:6 follow-up: Changed 7 years ago by SmileyChris

I was cursing ctrl-c for the cause of the problem, not the solution ;)

comment:7 in reply to: ↑ 6 Changed 7 years ago by Marc Fargas <telenieko@…>

Replying to SmileyChris:

I was cursing ctrl-c for the cause of the problem, not the solution ;)

I read "damn youR ctrl-c" instead of "you", ups! :))

comment:8 Changed 7 years ago by Fernando Gutierrez

  • Patch needs improvement set

Actually the NullBooleanField is also repeated in the second patch, the second one refers to the RegexField I think.

comment:9 Changed 7 years ago by Gary Wilson <gary.wilson@…>

  • Patch needs improvement unset
  • Summary changed from List fields in newforms documentation to document newforms fields

Ok, so who wants to start on widgets (#3800)?

comment:10 Changed 7 years ago by adrian

  • Resolution set to fixed
  • Status changed from new to closed

(In [5222]) Fixed #3780 -- Added first stab at 'Built-in Field classes' section to docs/newforms.txt, with help from SmileyChris and Marc Fargas

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.