Code

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#3692 closed (duplicate)

admin docs get confused by the decorator staff_member_required._checklogin

Reported by: Simon G. <dev@…> Owned by: adrian
Component: contrib.admin Version: master
Severity: Keywords: admin
Cc: dev@… Triage Stage: Unreviewed
Has patch: no Needs documentation: no
Needs tests: no Patch needs improvement: no
Easy pickings: UI/UX:

Description

The admin views documentation page (/admin/doc/views/) seems to get confused by django.contrib.admin.views.decorators._checklogin, this decorated gets listed as the view function for many of the admin pages.

	/admin/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/<var>/<var>/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/<var>/<var>/<var>/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/<var>/<var>/<var>/delete/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/<var>/<var>/<var>/history/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/<var>/<var>/add/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/auth/user/<var>/password/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/auth/user/add/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/bookmarklets/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/filters/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/models/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/models/<app_label>.<model_name>/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/tags/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/templates/<template>/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/views/
	View function: django.contrib.admin.views.decorators._checklogin

	/admin/doc/views/<view>/
	View function: django.contrib.admin.views.decorators._checklogin

I'm guessing that the decorate'ing isn't taken into account in admin.views.doc.view_index

Attachments (0)

Change History (2)

comment:1 Changed 7 years ago by mtredinnick

  • Needs documentation unset
  • Needs tests unset
  • Patch needs improvement unset
  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #1840, which contains a lot of discussion already about fixes and their trade-offs.

comment:2 Changed 7 years ago by Simon G. <dev@…>

Note to self: search first before submitting.

Add Comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
as The resolution will be set. Next status will be 'closed'
The resolution will be deleted. Next status will be 'new'
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.